What are the system requirements for Periscope Pro?

Curious on which version to download?

Just follow the guideline below, and click the version number to begin a download.

Periscope Pro V2 requires Mac OS 10.8 or later to be run.  

For Mac OS 10.6 - 10.7, be sure to check the Periscope Pro V1.


Feedback and Knowledge Base